17:00:27 <nickm> #startmeeting network team meeting NOW AT NEW TIME!
17:00:27 <MeetBot> Meeting started Mon Mar 28 17:00:27 2016 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:27 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:30 <nickm> Hi all!
17:00:36 <isabela> o/
17:01:02 <nickm> On-channel I see Sebastian dgoulet armadev isabela athena asn isis mikeperry !
17:01:06 <nickm> Not seeing teor or yawning
17:01:08 <asn> hello
17:01:23 <dgoulet> hi
17:01:31 <nickm> teor is probably asleep; with luck yawning is doing fine, sees his email and remembers the new time soon. :)
17:01:48 <nickm> So, quick checkins.  I'll start.
17:01:53 <armadev> hi (i'm going to try to derail the meeting less this time than i did last time. so ya'll can focus on the key things that need doing.)
17:02:06 <nickm> Last week I did lots & lots of alpha kludging, hoping to get an rc out, and it turned into an alpha.
17:02:11 <nickm> I corralled people into helping.  Thanks, folks!
17:02:25 <nickm> I got some stuff done on my modularity hacking, and finally published the manifesto there to tor-dev.
17:02:31 <nickm> More comments would be welcome.
17:02:45 <nickm> I also did a big pile of triage for 029 for isabela.
17:03:24 <nickm> This week I aim to release 0.2.8.2-alpha today, sprint on the S-eom stuff between now and Thursday, and take Friday mostly-off to celebrate "don't believe the internet day"
17:03:50 <nickm> I'm also planning to fork 0.2.9 when 0.2.8.2-alpha releases, but don't expect major changes there till early April.
17:03:53 <nickm> next?
17:04:05 <asn> oh wow ots of stuff
17:04:06 <asn> i can go next
17:04:15 <nickm> go for it!
17:04:18 <asn> i have prerecorded my msg
17:04:21 <asn> Hello. The past week I worked on prop224 and prop259:
17:04:22 <asn> https://lists.torproject.org/pipermail/tor-dev/2016-March/010629.html
17:04:25 <asn> https://lists.torproject.org/pipermail/tor-dev/2016-March/010625.html
17:04:26 <asn> I also reviewed some tickets, did triaging for 0.2.9 and looked at some gsoc proposals.
17:04:29 <asn> My review queue is empty again -- please give me something to review.
17:04:30 <asn> (Also my internet is very bad, I might drop at any point.)
17:04:47 <asn> that's that. next can go.
17:04:55 <nickm> #item for discussion: talk about stuff people can review
17:05:20 <Sebastian> I'll go
17:05:46 <Sebastian> I wrote the "how to test a controller feature using stem" thing as a patch to HACKING/WritingTests
17:05:49 <Sebastian> it's in needs review now
17:06:29 <Sebastian> the actual stem patch is not jet upstreamed because while doing what I was doing I found 6 stem bugs and 2 tor bugs, and one of the Tor bugs is a blocker (because I need to understand what the right behaviour is to test it)
17:06:34 <Sebastian> yet*
17:06:44 <Sebastian> (jetstreams anyone)
17:06:59 <Sebastian> next
17:07:29 * dgoulet can go
17:07:32 <nickm> woo!
17:08:06 <dgoulet> Last week was mostly code review, fixing bugs, ticket triage for 028/029 and trying clean up a bit the tickets with the "tor-hs" keyword. I was off friday to ease off.
17:08:23 <dgoulet> I emptied my "flagged messages" in my Inbox so I'm quite happy! which included some prop224 feedback to asn.
17:08:44 <dgoulet> I plan, for real this time, to do some code work on 224 this week once this alpha is out
17:08:45 <dgoulet> ---
17:09:10 <nickm> oh, karsten is on-channel too. :)
17:09:23 <nickm> #item for discussion: whom should I expect for the Patch Party time
17:09:50 <isabela> I can go next
17:09:53 <nickm> woo!
17:10:01 <isabela> Thanks for all the work on the tickets.
17:10:16 <isabela> Please keep marking the ones we should remove from the release
17:10:24 <isabela> I am working on sending the email to tor-dev about trac workflow
17:10:33 <isabela> I am taking this opportunity to build a diagram that we can use in our wiki to describe our code review flow
17:10:41 <isabela> here is a draft: https://storm.torproject.org/shared/dxorfnB3pjZOqeWSpcMWsWbBa00FVJcJQU4YlDJkXZY
17:10:45 <Yawning> morning
17:10:48 <nickm> isabela: how shall we mark the ones to remove from the release?  And how shall we decide
17:10:49 <isabela> another thing I would like to work with the team this week is to update the monthly tag
17:11:01 <nickm> A wild Yawning has appeared!
17:11:10 <isabela> nickm: I sent an email about it, people are marking as red in the spreadsheet
17:11:18 <nickm> #action everybody mark things as red in the spreadsheet.
17:11:21 <isabela> https://docs.google.com/spreadsheets/d/1ndnU4o0iMbXu0o02yTDurHIiGCDoIBV9hdV4YJQMWVs/edit#gid=0
17:11:22 <nickm> isabela: subject line on that email?
17:11:26 <isabela> I moved all the red ones to the bottom
17:11:36 <nickm> what's the timeline on that?
17:12:00 <isabela> tomorrow EOD? if it sounds doable by folks
17:12:30 <isabela> I sent an email to the list about it and also updated our wiki page with the queries for march and april
17:12:39 <isabela> (the monthly tag)
17:12:49 <isabela> lots of tickets that needs review without reviewer
17:12:50 <nickm> which list?
17:12:55 <isabela> network-team
17:13:11 <nickm> #action everybody make sure that you are on network-team
17:13:20 <nickm> #action make sure everybody is on network-team
17:13:21 <isabela> I sent an invite to people
17:13:27 <isabela> they should have it on their inbox
17:14:37 <nickm> ah.  subject line "confirm (lots of hex digits)" :)
17:14:53 <isabela> :)
17:15:26 <isabela> [done]
17:15:29 <nickm> I bet other people missed it too.
17:16:29 <mikeperry> I am also here, fyi, and on the network list (but still catching up on mail)
17:16:32 <nickm> #item discuss triage stuff
17:17:04 <nickm> isabela: I will try to mark things red by then, but we need to discuss things before we actually remove them.  Is that the plan?
17:17:10 <nickm> I see a couple of red things that worry me.
17:17:31 <isabela> yes
17:17:36 <Yawning> im onthe list
17:17:53 <isabela> I want to do a check in on wed and another one next monday
17:18:02 <isabela> that's why tomorrow EOD
17:18:05 <nickm> hm ok
17:18:30 <nickm> extra meetings this week will be tricky for me, given the sponsor S end-of-month sprint.  But I can be there.
17:18:49 <isabela> wed patch workshop
17:18:54 <isabela> we could do a check in right after
17:19:32 <isabela> ops
17:19:33 <isabela> sorry
17:19:35 <isabela> is tuesday
17:19:36 <nickm> y
17:19:40 <nickm> ah ok
17:20:09 <isabela> alright we do check ins after the team meetings :) that is what I meant
17:20:20 <nickm> ah
17:20:28 <nickm> ok.  next person to check in?
17:20:45 <Yawning> uh
17:20:52 <Yawning> working on testing stuff
17:20:57 <Yawning> I'll have something by end of the month
17:21:01 <nickm> how's it going so far?
17:21:03 <Yawning> migraines a refun
17:21:18 <Yawning> it's going
17:22:27 <Yawning> not really feeling inspired, but I'll hve something servicable
17:22:36 <nickm> ok. Thanks for that.
17:22:49 <nickm> I'm scrambling to get  stuff done on deadline here.
17:23:53 <mikeperry> I am still finishing up the Firefox networking review. I thought I'd finish by now, but by Thursday last week I started to run out of steam, and I realized that I hadn't had a weekend the week prior, so I took a long weekend.
17:23:59 <mikeperry> This week, I'm really going to finish the Firefox stuff, but am now wondering if I should switch to juggling Tor Labs and the Tor Blog, since if I don't pay attention to those, they will also continue to stall...
17:25:04 <mikeperry> tbh this Firefox review stuff is calming in itself, but long-term is messing with my calm. I feel like there's too many other things I should be doing, but "Just when I think I'm out, they pull me back in" ;)
17:25:34 <isabela> hehe
17:26:07 <nickm> anyone else here today?
17:26:14 <nickm> or shall we move to discussion?
17:26:21 <armadev> i am here. i just committed a changelog fixup, and am done with that. eom.
17:26:51 <nickm> ok, discussion.  We have these topics:
17:26:57 <nickm> - what to code-review
17:27:03 <nickm> - making 0.2.9 triage go well
17:27:22 <nickm> - who's coming to tomorrow's patch party?
17:27:33 <nickm> anything else to add?
17:28:25 <isabela> nope
17:28:39 <n8fr8> I'm here listening, hope to join on a more regular basis, just to listen and learn
17:28:57 * rl1987 lurking.
17:28:59 <nickm> ok.  so for code review, right now, nearly everything in needs_review for maint-0.2.8 is probably suitable.
17:29:12 <nickm> and nearly everything in maint-0.2.9 is probably worth _somebody_ looking at, but some of those are bigger.
17:29:32 <nickm> the biggest open thing in 028 right now is #18460 from karsten.
17:29:46 <nickm> #17744 and #18661 and #18673 and #18133 should be trivial.
17:30:11 <nickm> For document review, I'd love somebody to read my full modularity manifesto
17:30:19 <isabela> can we also take a look at the monthly tags? I added the reviewer column to the queries
17:30:22 <nickm> for 029, whatever you like!
17:30:30 <isabela> https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam
17:30:42 <nickm> https://trac.torproject.org/projects/tor/query?status=!closed&keywords=~TorCoreTeam201603
17:30:49 <nickm> https://trac.torproject.org/projects/tor/query?status=!closed&keywords=~TorCoreTeam201604
17:32:03 <nickm> I don't plan to review anything betwen now and thursday, but I might
17:32:34 <nickm> for my assigned items for March, I intend to deliver the alphas, and schedule them for review&merge in april.
17:32:52 <nickm> I expect some of the other items in march to possibly slip to april.
17:33:14 <isabela> ok
17:33:20 <nickm> please feel free to take ownership/reviewership on anything in mar/apr!
17:33:30 <isabela> lets see how we can at least ensure reviewers for the stuff you listed above
17:33:36 <nickm> I think there may be some april things that only I can review at this point.
17:33:54 <Yawning> I dunno what my arpil/may will look like
17:34:01 <Yawning> because it depends on what buracracy does to me
17:34:12 <Yawning> among other things
17:34:23 <dgoulet> nickm: if so, we can set  you as Reviewer in those tickets I guess?
17:34:29 <dgoulet> (basically the nickm-review keyword"
17:34:34 <nickm> sure.  I'll take a pass on it first though
17:34:39 <dgoulet> (or need_merge)
17:34:40 <dgoulet> ok
17:35:02 <isabela> since we dont have the need_merge there yet
17:35:14 <isabela> lets at least put a name on reviewer field
17:35:37 <dgoulet> ack
17:36:15 <nickm> oh, one more place to do triage:
17:36:33 <nickm> https://trac.torproject.org/projects/tor/query?status=!closed&keywords=~TorCoreTeam201602
17:36:41 <nickm> That is a list of what we said we'd get done in February.
17:36:51 <nickm> Note that there are 16 tickets left.
17:37:02 <nickm> I'm going to move them all out now.
17:37:03 <isabela> good catch
17:39:53 <nickm> done
17:40:02 <nickm> so, I think that's some talking-about-reviews.
17:41:07 <nickm> non-binding poll: would it be better if I tried just assigning people as reviewers?
17:41:54 <isabela> I think we should try
17:41:55 <dgoulet> I guess it could be a start and if the reviewer can't or won't review it, he/she can change it
17:41:59 <armadev> if nobody is signing up, might be the only option?
17:42:37 <Yawning> (am I needed immediately, or can I go off to find pain killers and work on code?)
17:43:05 <nickm> find pain killers and work on code, but please do the stuff labelled as #action above when you're feeling better, and try to make it to the patch party tomorrow night if you can?
17:43:22 <Yawning> I was going to work on code for the rest of the week
17:43:25 <Yawning> for the S stuff
17:43:47 <Yawning> im on the list already
17:43:52 <nickm> sounds good.  the #action stuff is small; just making sure that 029 happens and we don't kick out anything bad.
17:45:27 <nickm> next topic is what-to-do-for-triage
17:45:34 <GeKo> tor browser meeting in 14 minutes
17:45:55 <GeKo> (we can switch to #tor-project if necessary i guess)
17:45:58 <nickm> isabela: right now it's just "take things you think we shouldn't do, and mark them red by midday tomorrow?)
17:46:05 <nickm> GeKo: we'll be done soon I expect
17:46:08 <isabela> yes
17:46:38 <isabela> also, if you can add yourself as owner to tickets you will be working on
17:46:45 <isabela> 70% of tickets has no owner
17:46:54 <nickm> two questions.
17:46:57 <isabela> k
17:47:05 <nickm> 1) should I be conservative or generous with the red paint?
17:47:09 <nickm> s/I/we/
17:47:17 <isabela> generous (we are over committing)
17:47:38 <nickm> 2) should we put ourselves as owner on the stuff we would like to do, or stuff we WILL do?
17:47:44 <nickm> or somewhere in between
17:48:15 <isabela> you can do both, will and would like to do
17:48:34 <nickm> ok
17:48:47 <nickm> I'll be conservative about that myself, in hopes others will own stuff
17:48:52 * armadev owns one
17:48:55 <nickm> we should mark that on the tracker, yeah?
17:49:16 <isabela> you mean in the spreadsheet?
17:51:04 <nickm> should we mark owner on spreadsheet or in trac?
17:52:30 <isabela> doesn't matter, can be either I will spend time syncing things up tonight and tomorrow night as well
17:52:51 <nickm> ok
17:53:01 <nickm> anything else? anybody else haved questions on this triage stuff?
17:53:13 <nickm> it's less fun than code, but it will make us have a much nicer may...september
17:53:32 <dgoulet> all good here
17:53:44 <nickm> ok.  I will in that case endmeeting rsn!
17:54:04 <isabela> ok
17:54:05 <nickm> #endmeeting