16:59:21 <nickm> #startmeeting weekly tor-dev monday meeting, 18 April
16:59:21 <MeetBot> Meeting started Mon Apr 18 16:59:21 2016 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:59:21 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:59:40 <special> oh hey! my calendar has lied to me again
16:59:42 <nickm> I saw Yawning here a minute ago!  I've seen dgoulet and athena and isis and asn_ earlier today!
16:59:45 <Sebastian> hi
16:59:51 <nickm> hi Sebastian !
16:59:58 <special> it's quite late where I am but I'm around for a bit
16:59:58 <asn_> im around. pre-writing my status report for this week.
17:00:01 <nickm> special:
17:00:14 <nickm> https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam/MeetingSchedule is canonical.  Specifically, the UTC times.
17:00:30 <nickm> first, checkins:
17:00:44 <isis> hey hey
17:00:51 <nickm> - I tagged every sponsored ticket with a deliverable code from https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam/ReleaseGuidelines
17:01:03 <nickm> - I had a mostly relaxing weekend
17:01:08 <nickm> - I started a long bug retrospective
17:01:30 <nickm> - I wrote some code for april deliverables, including notably a more scalable timer implementation.
17:01:35 <nickm> - I did more on the bug retrospective
17:01:55 <nickm> - I tried to review and merge some stuff, and figure out a plan for getting all of my april stuff done, ha ha
17:02:03 <nickm> - I helped with proposal writing
17:02:12 <nickm> - probably more stuff i forgot i did
17:02:12 <nickm> next?
17:02:48 * ln5 is late but here
17:03:10 <asn_> i can go next
17:03:13 <asn_> Hello. Like the previous weeks, I continued working on prop224 and prop259.
17:03:15 <asn_> I'm cooking up a new torpec branch for the time period part of prop224. Also, I
17:03:18 <asn_> prepared some fixes to the issues that Nick found with the previous prop224 changes:
17:03:18 <Yawning> hi
17:03:19 <asn_> https://lists.torproject.org/pipermail/tor-dev/2016-April/010753.htmla
17:03:22 <asn_> When Nick approves the changes, I will merge them to torspec.
17:03:25 <asn_> I'm also trying to keep track of the throughtowrks prop259 progress. We are currently trying
17:03:28 <asn_> to figure out how to ensure consistency between multiple parallel runs of the
17:03:29 <asn_> algorithm (e.g. consider tor is trying to find a working directory guard, and
17:03:32 <asn_> then another part of tor is trying to find a normal guard at the same time. how
17:03:33 <asn_> should the sampled guard list be manipulated in this case?)
17:03:36 <asn_> I also gave a talk about Tor & PTs in a big greek FOSS conference.
17:03:37 <asn_> I also did a bit of review on #17799 and today I started testing the PRNG
17:03:40 <asn_> output using dieharder.
17:03:41 <asn_> that's that.
17:03:44 <asn_> next?
17:04:12 <nickm> #action nickm review https://lists.torproject.org/pipermail/tor-dev/2016-April/010753.htmla
17:05:16 <nickm> asn_: that email says that you already merged them to torspec?
17:05:21 <nickm> (who's next?)
17:05:39 <asn_> oops im sorry pasted wrong URL. this is the right one: https://lists.torproject.org/pipermail/tor-dev/2016-April/010775.html
17:06:09 <nickm> #action actually nickm reviews https://lists.torproject.org/pipermail/tor-dev/2016-April/010775.html
17:06:26 <Yawning> uh
17:06:37 <Yawning> reviewed the rng branch, worked on obfs5
17:06:46 <Yawning> https://git.schwanenlied.me/yawning/basket2
17:06:56 <Yawning> handshake/framing is mostly done
17:07:11 <Yawning> need to implement padding and sending data
17:07:42 <Yawning> (X25519 for handshake auth, and either X25519 + newhope or X448 + newhope for key exchnage)
17:08:34 <Yawning> unless I screwed up, user data will be secure till the sun swallows the earth
17:08:43 <Yawning> especially if you use X448
17:09:13 <Yawning> plans for the week are, to get it pushing bytes
17:09:24 <Yawning> and pad
17:10:26 <Yawning> handshake perf isn't as good as I'd want but it's acceptable given the paranoia (550 us for X25519, 2 ms for X448)
17:11:44 <Yawning> if I should be doing other things let me know
17:12:03 <nickm> let's figure out what else is in April as we discuss?
17:12:19 <nickm> dgoulet / isis / athena / Sebastian / anybody else to checkin?
17:12:28 <isis> sure
17:12:46 <isis> i had a meeting with shari to figure out if/how i would be able to work on tor part-time while doing my ph.d.
17:12:52 <nickm> cool
17:13:05 <Yawning> (oh yeah, I should figure out my contracting situation sooner rather than later)
17:13:18 <isis> and i dealt with paperwork/taxes and the giant pile of email that had built up in the last few weeks
17:13:47 <isis> and then i started working on a proposal for a PQ-secure hybrid handshake that is also X25519 + newhope
17:14:17 <isis> well, NTor + newhope
17:16:06 <isis> and i started cleaning up my prop#226 and prop#188 branches
17:16:45 <isis> oh, i guess i should change the status of prop#226
17:16:55 <isis> that's it for me
17:17:04 <nickm> ok
17:17:11 <nickm> dgoulet / athena / Sebastian / others?
17:17:41 <isis> also if there is something i can review or otherwise do, please let me know
17:17:58 <mikeperry> I am here
17:18:02 <nickm> let's divvy stuff up during the discussion part?
17:18:05 <nickm> (thanks for the offer!)
17:18:08 <nickm> mikeperry: hi mikeperry !
17:18:09 <mikeperry> Last week, I worked on the OTF proposal, the Firefox review, taxes, and helped with some other org stuff.
17:18:35 <mikeperry> This week, I will be finishing up the OTF proposal this week, finishing the Firefox review, and hopefully reviewing #18365, #18362, #14881.
17:19:15 <nickm> mikeperry: if you can I'd like to talk about integrating #18365 and #18362 in your big pending branch to simplify it. That's something I'd be able to help with I think, but I could use your help.
17:19:38 <mikeperry> yeah, I will be thinking about that when I review it
17:19:47 <mikeperry> haven't yet looked
17:19:58 <nickm> ok
17:20:24 <nickm> who else has a checkin?  (/me wants us to finish before the hour is out)
17:21:18 <nickm> huh. I guess we move on to discussion, and if anybody else is around, they can check in when they remember the meeting time
17:21:54 <nickm> so, here's April: https://trac.torproject.org/projects/tor/query?status=accepted&status=assigned&status=merge_ready&status=needs_information&status=needs_review&status=needs_revision&status=new&status=reopened&keywords=~TorCoreTeam201604&group=status&col=id&col=summary&col=keywords&col=status&col=owner&col=priority&col=reviewer&order=priority
17:22:26 <nickm> we have a few needs_revision tickets without an owner, and a bunch of needs_review tickets without a reviewer.
17:22:57 <nickm> also there are two tickets in "new". I'm listed as owner of one of them but I'd be happy to hand it off
17:23:15 <nickm> On the bright side, once I'm farther along with stuff I hope I can get a lot of review done.
17:23:30 <nickm> Folks who were interested in 'something more to do' -- is there anything you feel keen reviewing there?
17:23:42 <Yawning> well, I kind of want to know
17:23:44 <nickm> isis: should your #7144 and #17262 be in April ?
17:23:53 <Yawning> if it's ok for me to sit in my code cafe just poking at obfs5
17:24:00 <Yawning> or if I should be working on other things
17:24:21 <nickm> Yawning: I think obfs5 is okay for this week, but I really would like everybody to take on reviewing one or two things without a listed reviewer.
17:24:46 <nickm> otherwise I'm the reviewer by default for 15 currently unclaimed tickets.
17:24:56 <Yawning> I'll review more stuff
17:25:02 <Yawning> when ever obfs5 fills me with rage
17:25:24 <nickm> Yawning: okay. Can you add yourself as "reviewer" to a couple of things on that keyword?
17:25:38 <asn_> i need to do some more #17799 review, but i can take another ticket for review this week.
17:25:53 <nickm> also everybody should look at the stuff in that query where they are listed as "owner" and make sure that you really are going to have it done in april.
17:25:54 <asn_> i wonder which one hsould that be. im trying to copy paste that huge trac line above.
17:26:21 <nickm> it's just a search for "not closed, keyword=TorCoreTeam201604"
17:26:31 <Yawning> at some point I need to revise my parallel circuit build crypto branches too
17:26:57 <isis> oh, i guess there's the #17262 stuff to review
17:27:13 <isis> nickm: yeah, #7144 and #17262 can both be in april
17:27:16 <nickm> great
17:27:38 <isis> wait does that mean "done completely and merged completely" in april, or?
17:27:50 <asn_> i can take #15621
17:28:06 <nickm> probably "done and reviewable (and reviewed and merged only if possible)"
17:28:14 <nickm> asn_: thanks
17:28:16 <isis> it is possible to get both done, okay
17:28:21 <asn_> there i put myself as the reviewer
17:28:24 <nickm> thanks
17:28:45 <nickm> isis: don't stress yourself out; many things are only in april because I wanted to prioritize reviewing where code already existed.
17:29:27 <nickm> (That said, reviewing and merging stuff early is still a great idea.)
17:29:44 <Yawning> one thing I really want to do is to start using more assembly for certain things in our code
17:29:57 <Yawning> but, that's something I'll argue about later I guess
17:29:58 <nickm> #16792 should be an easy review
17:30:27 <nickm> armadev already complained about it some, but nobody wrote up a review. :)
17:30:45 <Yawning> (specifically BMI/AVX2  on Intel, NEON on ARM)
17:31:46 <nickm> Yawning: that sounds cool but please also take a moment to look at what our september commitments are.  That might fit in someplace, but we _do_ have to do the Sponsor*-Must items.
17:32:00 <asn_> btw is there anything triaging-related that the SponsorR team needs to do?
17:32:05 <isis> i put myself as the reviewer for #16792
17:32:16 <Yawning> yeah
17:32:45 <nickm> asn_: look at https://trac.torproject.org/projects/tor/wiki/org/teams/NetworkTeam/ReleaseGuidelines and see how there's a "SponsorU deliverables" and "SponsorS deliverables" section.  The SponsorR section there is empty. :)
17:33:00 <Yawning> I still have no idea if I should be doing pt stuff or core tor stuff
17:33:24 <nickm> Yawning: I'd like you doing some of each if that's a way you're comfortable working.
17:33:37 <Yawning> (rationale for the assembly is, our ARM performance is utterly horrible)
17:34:27 <asn_> nickm: i have noticed this as well. one of the issues might be that the way that the SponsorR deliverables   are phrased in the sponsor documents, is a bit misleading.
17:34:40 <nickm> maybe talk with isabela about that?
17:34:47 <asn_> since writing that deliverable text a few years ago we have refined our goals quite a bit.
17:34:48 <asn_> ack
17:34:52 <nickm> the important thing is that you and the sponsor need to agree about what you committed to actually do...
17:34:59 <nickm> and that you need to have it written down someplace...
17:35:07 <asn_> right
17:35:08 <nickm> and that there should probably be tickets matching up to it.
17:35:24 <nickm> It woudl be sad to reach the end of the contract and find out that there was no documentation of the understanding you thought you had reached. :)
17:35:45 <asn_> ack. will discuss this with dgoulet and figure something out.
17:35:57 <nickm> thanks!
17:36:03 <asn_> we do have marked tickets with SponsorR-must. if these tickets are done, we think the sponsor will be happy.
17:36:04 <nickm> isis: thanks!
17:36:25 <asn_> but ill also try to figure out what to write on that wiki page
17:36:35 <Yawning> (takes 18402 for review)
17:36:38 <asn_> dgoulet: ^ any thoughts?
17:36:38 <nickm> more to say on the April list of stuff, or shall we move on to the next weekly thing...
17:36:41 <nickm> Yawning: thanks!
17:37:19 <nickm> here are the tickets somebody has listed as 029-proposed this week
17:37:33 <nickm> https://trac.torproject.org/projects/tor/query?status=!closed&keywords=~029-proposed&group=status&col=id&col=summary&col=keywords&col=status&col=owner&col=priority&col=reviewer&order=priority
17:37:35 <Sebastian> hrm, my internet sucks. But I have nothing to report, just listen anyway
17:38:05 <dgoulet> (oh hi!... sorry lost power at my house for the last hour and a half! just came back)
17:38:26 <nickm> dgoulet: hi!
17:38:48 <dgoulet> I'm reading the backlog so please continue
17:38:51 <nickm> dgoulet: we just did checkings and looked over the april deliverables. I'm still hoping for folks to review their reviewables, etc.
17:38:58 <nickm> now we're talking about https://trac.torproject.org/projects/tor/query?status=!closed&keywords=~029-proposed&group=status&col=id&col=summary&col=keywords&col=status&col=owner&col=priority&col=reviewer&order=priority
17:39:01 <dgoulet> ack
17:39:12 <nickm> 3 of them are in needs_review.  I think we can at least review them if they're really needs_review. Any objection?
17:40:10 <nickm> ok, adding them in.  What about the other 7 ?
17:40:50 <dgoulet> I would like #13953 in 029 (see last two comments)
17:40:54 <nickm> anybody want to argue for/against/wait a week?
17:41:41 <dgoulet> seems #18828 is probably important also
17:41:54 <nickm> I agree about #18828.
17:43:07 <nickm> How hard is the fix on #13953 ?
17:43:10 <dgoulet> why do we put "029-accepted" if the ticket is set in the 029 milestone?
17:43:13 <nickm> It seems complex and ill-specified
17:43:30 <nickm> dgoulet: to track that it was not there at the original triage time.
17:44:03 <nickm> #18815 seems like a one-line fix.
17:44:10 <dgoulet> nickm: unsure but it could be a bit of work... it's just bad imo since reachability testing can be done on an IP that has nothing to do with ORPort...
17:44:40 <nickm> well, it's for the self-test
17:44:45 <nickm> and it's not making the network fall over.
17:45:01 <nickm> though it is confusing people apparently.
17:45:27 <nickm> I wonder if there's a simple fix that just adds a log to explain what we're testing, why, and what to do if you want us to test something else.
17:45:35 <GeKo> 14 minutes to tor browser meeting
17:45:36 <nickm> maybe we should think harder and come back to this one next time?
17:46:15 <dgoulet> nickm: I set "ORPort IP1" and then the testing is done on IP2 which is not even in the torrc... so 1) your relay fails to work properly because IP2 can be blocked or whatever, 2) maybe IP2 shouldn't have _any_ outbound data
17:46:36 <dgoulet> (which both are bad)
17:47:59 <nickm> I don't like it, but it's really about the semantics of Address vs FooPort. Revamping those in a way that won't confuse people even more is a tricky thing.
17:48:06 <nickm> I do agree it's not a great situation though.
17:48:19 <nickm> Let's talk more about it after the meeting, and next week too.
17:48:34 <nickm> do we want to accept/reject/defer any of the other items in 029-proposed?
17:50:14 <dgoulet> hrm... they are mostly all "good to have" but if we want to cut it short, I would say defer.. :S
17:50:39 <nickm> ok
17:50:45 <nickm> I'm just doing #18815 because it's trivial.
17:50:49 <nickm> anything else for discussion today?
17:51:57 <ln5> i think that the cosigning proposal is interesting but needs more info if the goal is that someone would be able to implement it
17:52:45 <Yawning> (is 2 ms/obfs5 handshake too slow?)
17:53:05 <Yawning> (1.6 ms of that is the 2 X448 scalar multiplies)
17:53:13 <nickm> dunno; how loaded are the obfX bridges now?
17:53:20 <nickm> how much of that is negotiation?
17:53:35 <Yawning> a negligible amount
17:53:47 <nickm> Can you make them do that work without knowing their public key?
17:53:50 <Yawning> I send pk (elligator2) | digetst | <encrypted/authenticated data>
17:53:51 <Yawning> no
17:53:59 <Yawning> same model as obfs4
17:54:01 <nickm> doesn't seem that bad then.
17:54:06 <nickm> but maybe ask around
17:54:13 <Yawning> using x448 is optional
17:54:24 <Yawning> you can reject/early abort
17:54:28 <Yawning> before doing the x448 math
17:54:50 <Yawning> I can get a 2x speedup by increasing the limb size in the x448 code
17:54:53 <Yawning> but I haven't bothered yet
17:55:33 <Yawning> my plan is to efault to x25519, bridge operators at their leisure can enable x448
17:56:02 <mikeperry> newhope is measured in us, right? I wonder if doing newhope + 25519 in a break-both handshake is better than messing with x448 at all?
17:56:25 <Yawning> well that's the performance for x448 + newhope
17:56:30 <Yawning> the default is x25519 + newhope
17:56:34 <Yawning> (550 us)
17:56:55 <Yawning> nb: my newhope is vectorized
17:57:10 <Yawning> because I use avx2 for the chacha20 when available
17:57:19 <Yawning> the newhope NTT/inverse NTT are not (yet)
17:57:27 <nickm> any more for the meeting or shall we move to #tor-project and let our TB friends meet? :)
17:57:40 <nickm> ok, thanks all!
17:57:41 <nickm> #endmeeting