17:01:34 <nickm> #startmeeting weekly network team meeting
17:01:34 <MeetBot> Meeting started Mon Apr 25 17:01:34 2016 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:01:34 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:01:38 <nickm> hi hi hi
17:01:43 <nickm> we'll start with checkins!
17:02:22 <nickm> I've been working on code review, merging stuff, fixing up my patches as people find issues with them, categorizing tickets, getting the bug retrospective done, and did I say code review? :)
17:02:57 <nickm> In the rest of this week I aim to finish the bug retrospective and finish fixing-my-patches and review more code.  Also I must help Isa with a sponsorS report, and did I mention more code review
17:02:58 <athena> i've done a bunch of backport tickets recently; looks like we finally have none left before 0.2.8, and some code reviews.
17:03:24 <athena> i take it you're going to ahead and drop the absolute timeouts from #18365, nickm?
17:04:30 <nickm> I think so
17:05:19 <nickm> They don't have a would-be user right now.
17:05:20 <Yawning> hi
17:05:23 <nickm> hi Yawning!
17:05:32 <athena> hi hi yawning
17:05:38 <Yawning> poking at obfs5
17:05:58 <Yawning> it might actually hand shake and relay bytes, though obfuscation still needs more work
17:06:03 <Yawning> since only the null padding is implemented
17:06:16 <Yawning> probably the last PT I'm going to write in go
17:06:34 <Yawning> because having to replayce parts of the runtime is dumb
17:07:01 <Yawning> See: https://github.com/golang/go/issues/11833
17:07:11 <Yawning> for "how not to implement a cryptographic entropy source"
17:07:21 <Yawning> (Yes, I fix that)
17:09:38 <mikeperry> nickm: I am here
17:09:53 <nickm> hihi!
17:09:58 <Yawning> I apparently am also allowe to do business
17:10:00 <mikeperry> I finished the Firefox networking review finally. still need to get to the tor reviews
17:10:03 <Yawning> according to the government
17:10:10 <Yawning> so yay I guess
17:10:18 <isabela> I sent an email yesterday reminding folks that we are at the last week of the month. we should be reviewing april tag and adding things to may tag
17:10:35 <nickm> Yawning: we should get together and get your deliverables and contract hammered out so that we're clear what you want to do and you're clear what Tor can pay you for doing. :)
17:10:52 <isabela> yes, I was writing an email to you two about it :)
17:11:05 <nickm> Ideally the overlap amounts to as much money/work as you like.
17:11:57 <Yawning> yeah
17:12:44 <Yawning> I'm mostly happy with how obfs5 is coming along
17:13:01 <Yawning> I'll document and post to tor-dev@ once I have something feature complete
17:13:25 <Yawning> I'm 99% sure life will be a lot better for the default bridges with the new code
17:13:42 <Yawning> for varying amounts of "a lot better" depending on if I want to write a poly1305 or not
17:14:23 <Yawning> next ish?
17:14:30 <isabela> Yawning: I will write a note about you coding obfs5 for the q1 report I am doing for sponsorS
17:14:49 <isabela> Yawning: I show you so you can review, ok?
17:15:26 <Yawning> yeah
17:15:33 <Yawning> note
17:15:37 <Yawning> name not final
17:15:48 <Yawning> it likely isn't going to be obfs5 unless there is a reason for it
17:16:11 <isis> hi! sorry i'm late
17:16:16 <nickm> no worries
17:16:19 <nickm> who else has a checkin?
17:16:26 <isis> i got lost in a sheep field again
17:17:00 <isabela> :)
17:17:03 <Yawning> baaaaaa
17:17:19 <isis> i can checkin
17:17:46 <isis> i reviewed #16792 and started to review #8185
17:18:30 <isis> for the latter, i used to hit what i think is that bug, but then i tried to trigger it on a bunch of version with chutney and couldn't
17:18:41 <isis> when i used to be able to trigger it in chutney
17:18:50 <isis> so i'm not sure what to do with that one
17:20:02 <isis> i also went over my #7144 patches and found that the tests were failing due to my rebase leaving out a line of initialising part of a mocked structure in the unittests
17:20:32 <isis> so i fixed that, wrote more tests, and then rebased onto master for 0.2.9.x
17:21:01 <isis> i need to test it more, and i still have a few more comments from nickm's review to address
17:21:32 <isis> i also read yawning's newhope code and obfs5 code
17:21:38 <isis> i think that's it for me
17:22:33 * isis goes to read scrollback
17:22:43 <Yawning> yawning's gigantic piles of insanity?
17:22:44 <Yawning> >.>
17:22:45 <nickm> ok. anybody else?  mikeperry / asn_ / dgoulet / ... ?
17:24:33 <arthuredelstein> mcs: I'm looking at the patch for #7920 (aka #6786). For upstreaming to Firefox, do you think this needs to be behind a pref?
17:25:21 <arthuredelstein> Or is that code only active when the "ui.use_standins_for_native_colors" is enabled?
17:25:40 <nickm> arthuredelstein: meeting in progress, fyi :)
17:25:49 <arthuredelstein> oops, sorry
17:26:03 <nickm> ok, let's move  on to discussion and hope that mikeperry/ asn_/ dgoulet show up as we're doing so.
17:26:12 <nickm> (with checkins)
17:26:15 <nickm> oh wait, mikeperry gave one
17:26:16 <nickm> sorry, mike
17:26:20 <mikeperry> yeah
17:26:23 * nickm has no short term memory
17:26:28 <isabela> I think dgoulet is busy in dc with armadev
17:26:32 <nickm> ok
17:26:59 <nickm> So, topics for discussion?  (if any.  We're not obliged to use a whole hour)
17:27:04 <nickm> I have a couple
17:27:11 <nickm> 1. Reviews reviews reviews!
17:27:35 <nickm> 2. what to do approaching end-of-month.
17:27:40 <nickm> 3. 0.2.8.next
17:27:50 <nickm> isabela: what do you have?  and do  we have more?
17:27:53 <isabela> (i wonder if special got gerrit set up
17:27:56 <isabela> )
17:28:20 <nickm> (I've been using cakelab as a review engine for the prop250 branch.)
17:28:21 <isabela> nickm: I think you cover it - btw I updated the wiki page to have april and may tags
17:28:28 <nickm> nifty
17:28:58 <nickm> oh, here's a bookkeeping question.  Should I remove the April tag from stuff that won't happen in april now, or should we do this as part of may planning?
17:29:09 <nickm> and should we be tagging stuff for may this week, or next?
17:30:44 <isabela> we should start this week - because for all the things on april, you will have to decide if 1) will be close by EOM so nothing need to be done 2) should be moved to May to be finished 3) won't get this done now or later, remove monthly tag .. will be picked up another time
17:31:04 <nickm> ok
17:31:05 <isabela> first week of may we will check what is the situation looking like for may
17:31:23 <nickm> is it important to track what we _thought_ would happen in april, to know how much we postponed ?
17:32:24 <isabela> yes
17:32:34 <isabela> i wonder how tho
17:32:50 <isis> so we should leave the april tag and just append a may tag?
17:34:01 <isabela> without an appropriated plugin for tracking this stuff is hard to have a way that is not funky :)
17:35:05 <nickm> we could add a deferred-from-april tag?
17:35:42 <isabela> sure
17:36:11 <nickm> ok.
17:37:20 <isis> isabela: is there a plugin which would help you track this sort of thing?
17:38:28 <isabela> isis: yes but I am not sure about the quality of the code/maintainance
17:39:36 <isabela> https://trac.edgewall.org/wiki/AgiloForScrum
17:40:47 <isabela> nickm: for 1. reviews reviews reviews
17:41:01 <isabela> I wonder how the first review and 2nd review is going
17:41:04 <nickm> yes!
17:41:19 <nickm> sometimes first review happens and 2nd review goes fast and I merge.  That's my favorite.
17:41:26 <isabela> hehe
17:41:35 <nickm> sometimes during 2nd review I throw it into needs_revision.  That slows things down.
17:41:50 <nickm> Sometimes first-review doesn't happen so much.  That's a problem.
17:42:08 <nickm> we have 5 needs_review tickets with no reviewer, and 12 other needs_review tickets.
17:43:39 <isabela> we should check how long tickets stay on need review state
17:43:45 <isis> i just assigned myself to review #18240
17:44:00 <isis> so now we only have 4 :)
17:44:35 <isabela> \o/
17:44:40 <isis> i am tempted to put #8185 into 'needs_information' state as well
17:45:31 <isis> since i'm not sure how i'm supposed to review cipherpunk patches when i can't even trigger the bug anymore for some reason
17:47:07 <isis> actually i think i will do that, if nobody objects
17:47:16 <nickm> go for it; be bold
17:47:25 <nickm> I've set myself as reviewer on #18685.
17:47:58 <nickm> the hard parts of #17158 and #18749 are related to teor's python fallback-list code.
17:48:32 <nickm> #17983 needs review (which should be easy) and a little hard thinking by somebody who likes crypto and compilers.
17:48:43 <nickm> and that leaves #17101 with no reviewer.
17:49:10 <nickm> #action for everybody:if you are listed as reviewer and you won't be reviewing this week, see if you can get somebody else to do it :)
17:49:29 <Yawning> is there a way to check to see what
17:49:33 <Yawning> I'm a reviewer for
17:49:57 <nickm> You can do a search by fields.
17:50:13 <nickm> you can add the reviewer column to the trac list view by clicking on the '> columns' thing near the head of the search results
17:50:37 <nickm> for april tickets, you (yawning) are currently listed as reviewer on #18402.
17:50:53 <nickm> asn is on #17799 and #18607
17:51:04 <nickm> dgoulet on #18363 and #18616
17:51:12 <Yawning> oh ok
17:51:15 <nickm> isis on #8185 and #18240
17:51:27 <nickm> mikeperry: on #7478 and #14881
17:51:40 <nickm> nickm on #16861, #17592, #17604, and #18685.
17:51:55 <nickm> nobody on #17101, #175158, #15983, and #18749.
17:52:05 <nickm> (that's only for needs_review tickets)
17:52:59 <nickm> (that's only for needs_review tickets in TorCoreTeam201604)
17:53:19 <nickm> but if everybody does two reviews early this week, we'll be in such a happy place.
17:53:29 <nickm> isabela: anything more to add?
17:54:51 <isabela> i will try to build a report first week of may for us to learn more about how we are doing
17:54:55 <isabela> that's all :)
17:55:06 <GeKo> tor browser meeting in 4 minutes
17:55:15 <nickm> ok. any more for us for today? :)
17:55:25 <nickm> 0.2.8.next I guess
17:56:09 <isabela> yes, please follow teor1 orientation for 0.2.8 prioritization
17:56:16 <isabela> while electing tickets for may
17:56:17 <isabela> :)
17:56:20 <nickm> makes sense.
17:56:28 <nickm> ok, thanks everybody!
17:56:31 <nickm> #endmeeting