#tor-dev: revised revised prop#259: more talking about guards.

Meeting started by nickm at 13:59:28 UTC (full logs).

Meeting summary

    1. https://gitlab.com/asn/torspec/merge_requests/3/diffs (nickm, 14:00:21)
    2. ACTION: try to think of ways that the "don't add to USED_GUARDS till we use it" rule can be manipulated by an attacker (nickm, 14:22:11)
    3. https://gitlab.com/asn/torspec/merge_requests/3/diffs#note_12742458 (asn, 14:30:47)
    4. ACTION: either convince myself that the retry logic does good things for HS clients/services when all primary, or change it so it does. (nickm, 14:39:19)
    5. ACTION: nickm can primaryness be a continuum? (nickm, 14:44:25)
    6. https://github.com/twstrike/tor_guardsim/tree/develop (rjunior, 15:07:03)
    7. https://pad.riseup.net/p/draft-guard-steps (nickm, 15:12:58)


Meeting ended at 15:34:59 UTC (full logs).

Action items

  1. try to think of ways that the "don't add to USED_GUARDS till we use it" rule can be manipulated by an attacker
  2. either convince myself that the retry logic does good things for HS clients/services when all primary, or change it so it does.
  3. nickm can primaryness be a continuum?


Action items, by person

  1. nickm
    1. nickm can primaryness be a continuum?
  2. UNASSIGNED
    1. try to think of ways that the "don't add to USED_GUARDS till we use it" rule can be manipulated by an attacker
    2. either convince myself that the retry logic does good things for HS clients/services when all primary, or change it so it does.


People present (lines said)

  1. asn (123)
  2. nickm (119)
  3. rjunior (24)
  4. fanjiang (14)
  5. iapazmino (6)
  6. athena (6)
  7. olabini (5)
  8. dgoulet (3)
  9. MeetBot (2)
  10. special (2)
  11. ron_ (1)


Generated by MeetBot 0.1.4.