17:00:22 <nickm> #startmeeting weekly network team meeting
17:00:22 <MeetBot> Meeting started Mon May 22 17:00:22 2017 UTC.  The chair is nickm. Information about MeetBot at http://wiki.debian.org/MeetBot.
17:00:22 <MeetBot> Useful Commands: #action #agreed #help #info #idea #link #topic.
17:00:37 <marrowgari> hello
17:00:45 <pastly> ayyyy
17:00:52 <nickm> hi ahf asn dgoulet isabela yawning (not here) teor (asleep) catalyst komlo haxxpop pastly Sebastian isis and whoever else I forgot to type!
17:00:55 <catalyst> hi
17:01:08 <nickm> This week's pad is at http://5jp7xtmox6jyoqd5.onion/p/W7DaURZyD2hO
17:01:12 <nickm> thanks to teor for setting it up
17:01:22 <komlo> hello!
17:01:28 <nickm> also at https://pad.riseup.net/p/W7DaURZyD2hO
17:01:41 <nickm> let's start by getting the pad more full and asking each other questions!
17:03:34 <Sebastian> hi
17:03:36 <mikeperry> For the people going to the Guard meeting/hackfest, does the agenda look plausible and likely to lead to actionable outcome? I only bothered with the Guard portions. I figure the hackfesty things can be filled in by others who want specific non-Guard things
17:03:39 <nickm> catalyst: wrt bootstrapping and UX discussions, we've seen a bunch of "no, not like that, like this instead" questions/suggestions from people
17:04:03 <isis> o/
17:04:16 <nickm> hello mikeperry , marrowgari !
17:04:45 <nickm> mikeperry: link to agenda please?
17:04:47 <catalyst> yeah i think we need to reconsider the gauges approach. it's also clear that people have different expectations about what the progress bar should represent
17:05:05 <nickm> I think the guages is a good idea, but maybe nto actually solving the problem people want
17:05:19 <nickm> I also think that the requirements we've gotten there might be in conflict
17:05:29 <haxxpop> hi \o/
17:05:34 <nickm> hihi
17:06:52 <mikeperry> nickm: https://pad.riseup.net/p/WuVE2Z7zgB1J_hackfest
17:06:54 <catalyst> nickm: quite possibly
17:06:57 <nickm> catalyst: what do you think our next step is on that? as it stands I think mike's ideas about timeouts are good; that the "80%" bug really is a bug; and not much else
17:06:58 <mikeperry> asn sent it via email also
17:07:50 <nickm> agenda seems ok to me
17:07:53 <catalyst> nickm: sorry, where did mike make those comments? things are a bit spread out
17:08:05 <nickm> catalyst: I think he said a bunch of stuff on IRC last week after the meeting
17:08:12 <nickm> here and on #tor-project
17:08:26 <catalyst> ah ok, i think i have scrollback i can look at
17:08:47 <nickm> also we have some comments on the 80% ticket (#22266)
17:08:51 <isabela> nickm: catalyst i would like to be looped on that discussion too
17:09:31 <catalyst> isabela: i can add you to CC on the related tickets that i know of, if that would help
17:09:42 <isabela> nickm: catalyst - i am working on notes about the tor launcher automation flow we discussed in sf
17:09:48 <isabela> catalyst: yes please
17:09:49 <nickm> isabela: ok. not sure the best way of how to do that. There's discussion on #22266 and some backlog I could try to dig up and send you with mikeperry and catalyst's permission
17:10:13 <catalyst> nickm: you have my permission
17:10:15 <isabela> thank you
17:10:37 <isabela> this tor launcher work is someething that touches a lot of different people work
17:10:43 <isabela> so is important to keep things in sync
17:11:14 <nickm> isabela: I think right now we're encountering a problem where we wrote up what we thought we were supposed to do after the meeting, and everybody said "No, not quite: instead of the ABC you wrote up, we really need XYZ"
17:11:18 <nickm> but everybody said a different XYZ
17:11:40 <nickm> and I'd like to be involved in the discussion to produce an XYZ ...
17:11:50 <isabela> yes
17:12:01 <isabela> that is what i am trying to fix
17:12:18 <isabela> to have one place where we define the experience
17:12:20 <nickm> but I don't think we can come up with a good result if we're the ones who are responsible for figuring out which requirements actually matter and what if anything we should actually implement
17:12:29 <isabela> so there is one version of it in one place
17:12:49 <isabela> i think the right process for when we are working on such a thing
17:12:57 <isabela> one feature that  involves a lot of different people/teams
17:13:04 <nickm> well, like i said, we _tried_ to do tha5t!
17:13:23 <nickm> so I think that there's more of a breakdown here than we thought
17:13:30 <isabela> is to have a brief about it where everyone understands how the feature should work and take from there what each person/team responsability are or requirements are
17:14:06 <isabela> nickm: i think this is one piece of the experience
17:14:26 <isabela> and this brief i am talking about will help you to see how your piece fits into it
17:14:33 <isabela> right now is confusing because that brief is missing
17:14:38 <nickm> ok. shall we suspend work until this is done?
17:14:54 <isabela> what is the work now planed for it?
17:15:45 <nickm> we wrote a spec for how to communicate accurate bootstrapping info
17:15:56 <catalyst> https://pad.riseup.net/p/OroadsO1qBgA
17:15:59 <nickm> everybody said that they wanted something else
17:16:17 <catalyst> we did get some agreement that the stuck-at-80% bug needs fixing, i think
17:17:02 <catalyst> people also seem to prefer a single linear progress bar but disagree on exactly what it should mean
17:17:35 <isabela> ok
17:17:55 <isabela> maybe for now look into the stuck-at80% bug and leave the progress bar on the side for a little bit
17:18:33 <isabela> because i think it will be hard to have a discussion in a ticket about the progress bar without taking into consideration other pieces from the experience
17:18:54 <nickm> well, it kinda _is_ about the progress bar though
17:19:07 <isabela> tat is why i would like to concentrate the part of where we define the experience in one place and from there people will know what they need to do to build the experience
17:19:15 <nickm> hnmrg.
17:19:16 <nickm> ok
17:19:54 <catalyst> some people think the progress bar should resume from where it left off. i think that tends not to accurately represent how long the user can expect to wait
17:19:58 <isabela> and i am sorry i havent seem this ticket
17:20:01 <nickm> I suspect that we'll find that there's less agreement than we think, but at least then we'll be arguing about the experience rather than assuming we all agree about the experience, and everybody telling me and catalyst we've got it wrong. :)
17:20:25 <isabela> nickm: exactly
17:20:36 <isabela> we need to all be on the same page of what that is and now is a lot of assumptions
17:20:45 <nickm> catalyst: we can also work on making timeouts smarter; we do know that we'll need that
17:20:51 <catalyst> isabela: the stuck-at-80 is #22266
17:21:46 <nickm> any more questions for folks on their updates?  If not, shall we move on to discussion stuff? :)
17:22:01 <catalyst> one fundamental disagreement as far as i can tell is whether a progress bar should measure "completion" for some abstract interpretation of that word, or whether it should represent an estimate of time remaining somehow
17:22:06 <isabela> is like writing a design proposal... i am trying to build a similar doc which we call product brief (or feature brief), once ppl agree on that it gets more clear what is the work that  needs to be done
17:22:48 <isabela> i am late on that, i tried to get it done last week but was too sick for it
17:23:20 <isabela> i hope to have it done this week and then we can start reviewing and hold a discussion to get to an agreement
17:23:31 <nickm> on to discussion topics? :)
17:23:52 <nickm> first one -- does anybody know any 0.3.1.1-alpha blockers?  If not, I mean to release after the meeting
17:24:25 <nickm> second -- teor wants to know what onion service info we'd like to have statistics about.
17:25:01 <nickm> I'm not sure I have a great handle on what we want to know there, but don't know... but I bet asn or dgoulet or armadev might have some good ideas
17:25:05 <nickm> anything on those two?
17:25:51 <nickm> hm. if not, let's think about the second, and get back to teor if we come up with anything?
17:25:52 <ahf> i have #22233 which i'm not sure if it's a blocker or not - i think it can easily wait, but there might be different opinions about that?
17:26:02 <ahf> it's the issue yawning found
17:26:38 <nickm> I don't think it's a blocker, unless we decide that what we must do in response to 0.3.1.1-alpha clients is something that 0.3.1.1.-alpha clients won't understadn
17:26:52 <nickm> How likely is that outcome (where we decide we need to break 0.3.1.1-alpha clients?)
17:28:10 <nickm> #action nickm sends backlog about ux ideas to isabela
17:28:38 <nickm> #action everybody makes sure to think about what kind of onion service stats would be safe and useful for improving the network?
17:28:46 <ahf> i'll have to check that out more thoroughly, but i don't think that outcome is likely
17:29:03 <ahf> but i want tests for this as well to ensure that we don't randomly break things as well
17:29:04 <nickm> ok. do you think you'll know in the next hour or two?
17:29:13 <ahf> yep
17:29:18 <nickm> great; please keep me posted :)
17:29:22 <ahf> will do
17:29:57 <nickm> next subject -- should we do more to make sure that as bugs are discovered in 0.3.0 and 0.3.1, they get fixed?  I think
17:30:25 <nickm> that when we're in feature freeze we're at risk of spending a bunch of time on 0.3.2 progress, and not as much on improving stable or stabilizing 0.3.1
17:31:27 <nickm> not sure what we should do there
17:31:30 <nickm> anybody have any ideas on it?
17:32:53 <nickm> maybe , everybody remember to look at the 0.3.0 or 0.3.1 milestones from time to time, and try to see if there's anything that could/should be assigned to somebody?
17:33:00 <ahf> i assumed we just stopped looking at feature/future things right now and started finding issues in some of the things that have changed recently and look at the bug lists during this period
17:33:07 <ahf> until the 0.3.2 window opens
17:33:23 <nickm> well, some folks are still going to be coding stuff for 0.3.2 to get it ready for the merge window, and that's fine...
17:33:33 <nickm> ...so long as it doesn't make 0.3.1 get delayed indefinitely
17:34:10 <ahf> yep
17:34:28 <nickm> maybe this should be part of the bug triage job?
17:34:32 <nickm> or a separate role?
17:35:52 <nickm> (is everybody too tired for this? should we call the meeting, take a nap, and go back to hacking? :) )
17:35:58 <catalyst> i've found that triaging of new bugs doesn't really catch very much. and i find searching through open bugs to be kind of cumbersome
17:36:18 <catalyst> sorry, i have no suggestions about how to make searching less cumbersome for now
17:36:41 <nickm> so, the stuff with a milestone attached is supposed to be higher relevance-to-now than other stuff...
17:36:52 <nickm> ...but that sure can be inaccurate.
17:37:17 <nickm> maybe we should plan some time between now and the 0.3.2 window to do a big attack on open tickets in tor:unspecified?
17:37:27 <nickm> and eg close or prioritize them?
17:37:37 <komlo> that sounds like a good idea
17:37:40 <nickm> similarly wrt tickets currently in 0.3.2.x?
17:38:04 <catalyst> to consider whether they need to be in 0.3.1 or 0.3.0?
17:38:15 <nickm> and to consider whether they need to be in 0.3.2.x at all
17:38:16 <pastly> Sooner might be better.
17:38:55 <nickm> how about tomorrow, I plan to spend all (or nearly all) my day on attacking trac, and people spend as much time helping as they feel like?
17:38:58 <nickm> and we see how far we get?
17:39:39 <ahf> sounds good!
17:39:41 <nickm> one thing to do as we do that would be the maintainance of "easy" or "intro" tickets, as suggested in a later topic on the pad
17:39:45 <komlo> that would be good as there is a patch party at the end :D
17:39:48 <nickm> ok. I'll email tor-dev, and invite folks to help :)
17:40:01 <catalyst> sounds good to me
17:40:10 <pastly> +1, FWIW from me
17:40:11 <marrowgari> sounds like the best plan fwd
17:40:20 <nickm> Please, everybody, promise to stop when it stops being fun. :)
17:40:38 <nickm> even if we don't get it all done, we'll know more about the shape of the problem space
17:40:44 <komlo> +1 to tagging easy/intro
17:40:46 <marrowgari> btw, i'm a little behind so just following along and looking for areas atm where i can jump in and help out
17:41:12 <nickm> ok!  So in theory there are tickets tagged with "easy" that are good projects for people starting out. unfortunately, a lot of them aren't as easy as they should be :/
17:41:27 <nickm> some tickets tagged "intro" may be good starting projects
17:41:40 <nickm> in general, improving test coverage with good tests is always welcome, any time
17:41:45 <marrowgari> nickm, teor, dgoulet: any helpful tips on where to get started in helping build out the fuzzer for v3 hidden services (#21509)? last i checked there were still a few outstanding items that I could possibly help out with or has this been resolved?
17:41:47 <nickm> anybody else have good suggestions?
17:42:12 <nickm> marrowgari: sure!  First thing to do is make sure you can get the existing tor fuzzer code working, as documented in doc/HACKING/FuzzingTor.md
17:42:20 <nickm> err,
17:42:23 <nickm> doc/HACKING/Fuzzing.md
17:42:38 <nickm> once you can do that, adding a new fuzzer is as easy as adding a new module in src/test/fuzz/
17:42:54 <marrowgari> great. i'll look into that. thx!
17:43:01 <nickm> as for which functions to fuzz: I think that the parsing might be best, but I think asn/dgoulet would have the best advice there
17:43:25 * pastly has to duck out now. leave things in the pad or mention me if needed
17:43:33 <nickm> last discussion topic: we should do more to try out the oniongit.eu instance that hiro made for us to try
17:43:37 <nickm> what should we do there?
17:44:00 <nickm> Sebastian, komlo: btw, is one of you working on a doc/HACKING/Rust.md ?
17:44:29 <komlo> nickm: yes
17:44:32 <nickm> awesome
17:44:48 <komlo> we have a rough one started but we need to update it. we can do that this/next week
17:44:57 <nickm> #action nickm emails tor-dev about tuesday as trac day
17:45:25 <nickm> komlo: also, it would rock to have a description of what our priorities are in rust/tor right now
17:45:39 <nickm> komlo: because I bet more people will show up once 0.3.1.1-alpha is out
17:45:55 <nickm> is there time to make a quick landing page to send people to when whey do so?
17:46:03 <komlo> nickm: definitely. we can put that together and review at the rust session at the hackfest?
17:46:25 <nickm> i was wondering if we could do something fast today, and improve it over time, maybe more at the rust session?
17:46:37 <komlo> landing page, as in wiki page?
17:46:39 <nickm> sure
17:46:50 <nickm> like, "here's the status, here are the priorities; more docs to come"
17:46:55 <komlo> sure, we can do that
17:47:03 <nickm> that would be so excellent
17:47:20 <komlo> yep, it is a good idea :)
17:47:32 <nickm> anybody any thoughts on getting more usage/experience on hiro's nice oniongit installation, so we can see how gitlab would work for us as a trac replacement?
17:48:29 <nickm> isabela: any thoughts on how we should go about learning more?  I guess we could just say "let's try using it for EVERYTHING we do internally for now, and see how we like it?"
17:49:14 <nickm> maybe something to figure out between now and 0.3.2?
17:49:46 <GeKo> who is "we"? just the network team?
17:50:05 <GeKo> i guess not as we don't want to end up with a different bug tracker per team?
17:50:38 <nickm> well, i had thought just the net team at first, to see if we even like it, and learn more about our requirements, before we recommend it to others
17:51:08 <GeKo> ok
17:52:44 <haxxpop> nickm, komlo What plan do you have with Rust ?
17:53:06 <nickm> haxxpop: in short: to have it as a first-class language in tor, if we can do so, eventually.
17:53:08 <haxxpop> implement some code with Rust ?
17:53:15 <nickm> but for now, to try it out and see what issues we run into
17:53:29 <isabela> nickm: i will think about it - i havent yet had the time to look into it
17:53:36 <haxxpop> nickm, Nice
17:53:39 <isabela> nickm: i can get back to the team over the email list
17:53:55 <nickm> haxxpop: and to have it there as  an option so that distributors can try building with it, and see what issues they run into
17:54:05 <nickm> before we even think of making it a requirement
17:54:10 <isabela> GeKo: the idea was to have the network team as a pilot to test it and see if its worth getting more teams doing it
17:54:21 <nickm> isabela: thanks!
17:54:32 <nickm> #action isabela thinks about getting oniongit.eu more tested, and sends email
17:54:35 <haxxpop> nickm, When the project starts, I'm really excited to help you guys!
17:54:36 <isabela> thanks
17:54:57 <nickm> #action komlo (with Sebastian?) gets a quick wiki page together for "so you want to help with tor-on-rust..."
17:55:11 <nickm> ok, any more for today? we are nearly out of time...
17:55:24 <nickm> #action nickm emails everybody the pad contents and a link to the meetbot url
17:55:55 <GeKo> isabela: interesting. was there any discussion anywhere i could follow?
17:56:13 <nickm> we had a few sessions at Amsterdam; there should be meeting notes
17:56:26 <isabela> GeKo: that has been many :) it stated on tor-project, then there was a meeting in ams
17:56:35 <GeKo> ah, okay. good
17:56:40 <isabela> GeKo: i will collect things and send your way
17:56:43 <nickm> https://trac.torproject.org/projects/tor/wiki/org/meetings/2017Amsterdam/Notes/Trac
17:56:43 <isabela> what about that?
17:56:55 <komlo> Sebastian: i'm starting a rough draft for the wiki and then will send to you to add to
17:56:57 <nickm> thanks, everybody!  Clearing this space for the next meeting. :)
17:57:01 <isabela> yeah this is part of that survey we did about trac
17:57:03 <nickm> #endmeeting