#debian-kernel Meeting

Meeting started by carnil at 20:00:02 UTC (full logs).

Meeting summary

    1. ACTION: waldi contacts d-i team about absorbing kernel-wedge into kernel-team linux.git (as only user) (carnil, 20:06:53)

  1. (carnil, 20:07:22)
  2. (carnil, 20:07:51)
  3. #1111095: (i, ) firmware-amd-graphics: Radeon HD 8280 : gpu lock, black screen and crash (carnil, 20:08:35)
    1. ACTION: bwh will ask the second reporter of #1111095 to check for open bugs or otherwise fill a separate bug, since problems seems unrelated (carnil, 20:12:14)

  4. #1115613: (i, +M) linux: Please enable CONFIG_SOUNDWIRE_AMD=m (carnil, 20:12:40)
    1. ACTION: carnil completes https://salsa.debian.org/kernel-team/linux/-/merge_requests/1650 with the minimal set of needed options to resolve #1115613 (carnil, 20:13:56)

  5. #1116251: (i, u) linux-image-6.12.48+deb13-rpi: Raspberry Pi Zero W does not boot (carnil, 20:14:18)
  6. #1116643: (i, Mu) UBSAN: shift-out-of-bounds in .../drivers/gpu/drm/display/drm_dp_mst_topology.c (shift exponent -1) (carnil, 20:16:20)
  7. #1123591: (i, u) reportbug: Kernel 6.17.11 "ixgbe"-driver broken (OEM Intel X540-AT2 card) (carnil, 20:16:57)
    1. ACTION: ukleinek will reply to #1123591 asking for tests with older kernels and a recent kernel log (ukleinek, 20:19:48)

  8. #1123750: (i, +u) linux: regression: virtual consoles 2-12 unusable (merged with #1124288, #1124340) (carnil, 20:20:23)
  9. #1125001: (i, ) linux-image-loong64: Backlight and touchpad doesn't work on laptop. (carnil, 20:21:16)
  10. #1038945: (n, ) linux: kernel null pointer dereference loading an invalid AppArmor profile, regression since 6.1 (carnil, 20:22:38)
  11. #1081195: (n, ) devscripts: test-patches KeyError: 'pae' (carnil, 20:23:22)
  12. #1120831: (n, u) linux: failed command: READ FPDMA QUEUED after boot (carnil, 20:25:50)
  13. #1121535: (n, +uM) linux-image-6.17.8+deb14-amd64: array-index-out-of-bounds trace during boot (...ctamixer.c:347:48) (carnil, 20:28:00)
  14. #1122035: (n, +) linux-image-amd64: Enable SimpleDRM to save laptops for GNOME 49 please! (merged with #993640, #1125148) (carnil, 20:28:56)
    1. ACTION: bwh looks for #1122035 and friends what the status around grub is, and how the edge cases where GRUB is still configured to break efifb can be handled (carnil, 20:33:28)

  15. #1122106: (n, Uu+) linux-image-amd64: UBSAN create a systematic trace in DRM driver (merged with #1122154) (carnil, 20:33:48)
  16. #1123648: (n, +) udeb: Add USB TYPE-C and mux modules in usb-modules for booting Debian installers (carnil, 20:34:44)
    1. ACTION: bwh reviews MR to address #1123648 (carnil, 20:39:08)

  17. #1124756: (n, ) linux-image-6.12.41+deb13-amd64: sporadic freezes (carnil, 20:39:37)
    1. ACTION: ukleinek forwards #1124756 to vendor (ukleinek, 20:42:57)

  18. #1124836: (n, ) linux-image-amd64: linux-image-6.18.3+deb14-amd64 introduced an ACPI warning (carnil, 20:46:29)
  19. #1124839: (n, ) linux-image-6.17 -- wireless does not wake up after standby (carnil, 20:46:54)
  20. #1125155: (n, ) /usr/share/bug/linux-image-6.12.57+deb13-amd64/include-pci: amdgpu flip timeout, system freezes (carnil, 20:50:42)
  21. carnil ask reporter of #1125155 to provide full logs including the amdgpu problems (carnil, 20:56:22)
    1. ACTION: carnil ask reporter of #1125155 to provide full logs including the amdgpu problems (carnil, 20:56:33)

  22. #1125287: (n, ) linux-image-6.12.63+deb13-amd64: Misleading error message "x2apic: IRQ remapping doesn't support X2APIC mode" (carnil, 20:57:58)
    1. ACTION: bwh will propose a patch for #1125287 (bwh, 21:00:10)

  23. #1125375: (n, ) linux-image-6.12.63+deb13-amd64: PCIe AER error storm on Intel Raptor Lake PCIe 5.0 root port with RTX 3070 Ti (carnil, 21:00:49)
  24. #1114857: (w, ) Switch default initramfs builder to dracut (carnil, 21:01:11)
  25. Migration excuses (carnil, 21:10:03)
  26. New upstream versions (carnil, 21:18:14)
  27. AoB (carnil, 21:19:45)


Meeting ended at 21:23:27 UTC (full logs).

Action items

  1. waldi contacts d-i team about absorbing kernel-wedge into kernel-team linux.git (as only user)
  2. bwh will ask the second reporter of #1111095 to check for open bugs or otherwise fill a separate bug, since problems seems unrelated
  3. carnil completes https://salsa.debian.org/kernel-team/linux/-/merge_requests/1650 with the minimal set of needed options to resolve #1115613
  4. ukleinek will reply to #1123591 asking for tests with older kernels and a recent kernel log
  5. bwh looks for #1122035 and friends what the status around grub is, and how the edge cases where GRUB is still configured to break efifb can be handled
  6. bwh reviews MR to address #1123648
  7. ukleinek forwards #1124756 to vendor
  8. carnil ask reporter of #1125155 to provide full logs including the amdgpu problems
  9. bwh will propose a patch for #1125287


Action items, by person

  1. bwh
    1. bwh will ask the second reporter of #1111095 to check for open bugs or otherwise fill a separate bug, since problems seems unrelated
    2. bwh looks for #1122035 and friends what the status around grub is, and how the edge cases where GRUB is still configured to break efifb can be handled
    3. bwh reviews MR to address #1123648
    4. bwh will propose a patch for #1125287
  2. carnil
    1. carnil completes https://salsa.debian.org/kernel-team/linux/-/merge_requests/1650 with the minimal set of needed options to resolve #1115613
    2. carnil ask reporter of #1125155 to provide full logs including the amdgpu problems
  3. ukleinek
    1. ukleinek will reply to #1123591 asking for tests with older kernels and a recent kernel log
    2. ukleinek forwards #1124756 to vendor
  4. waldi
    1. waldi contacts d-i team about absorbing kernel-wedge into kernel-team linux.git (as only user)


People present (lines said)

  1. carnil (134)
  2. bwh (67)
  3. ukleinek (67)
  4. waldi (13)
  5. MeetBot (3)
  6. KGB (1)


Generated by MeetBot 0.1.4.