#debian-kernel Meeting

Meeting started by carnil at 20:00:02 UTC (full logs).

Meeting summary

  1. #1126671: (S, ) linux-image-6.17.13+deb13-amd64: Disconect root (path=/) during heavy load on NvME, partial corruption on NTFS.crash soon but not yet (carnil, 20:03:17)
    1. ACTION: waldi take a look at #1126671 for further debugging and reply to reporter (carnil, 20:04:10)

  2. #1113728: (i, ) linux: new ABI versioning prevents linux-version and other tools from correctly sorting Debian revisions (merged with #1130656, #1131008, #1131108) (carnil, 20:04:29)
    1. ACTION: carnil take care of merging https://salsa.debian.org/kernel-team/linux/-/merge_requests/1854 and pick changes to other branches as labeled (carnil, 20:06:39)

  3. #1130605: (i, M) linux-image-6.19.6+deb14-amd64: hangs with kernel call trace when trying to sleep (carnil, 20:06:49)
  4. #1130775: (i, u) Regression: MDRAID 1.2 superblock created in Kernel 6.19 is rejected by older kernels (-EINVAL) (merged with #1130781) (carnil, 20:07:43)
    1. ACTION: bwh queries upstream about #1130775 (backwards-incompatible change) (carnil, 20:14:05)

  5. #1131158: (i, uM) linux: regression on ThinkPad T14s Gen 4 AMD: 6.18.15 backports fails to reach S0i3 on s2idle, 6.12.74 works (carnil, 20:14:17)
  6. #1111011: (n, M) RTL8125D - link drops (carnil, 20:16:19)
    1. ACTION: bwh will check whether newer PHY firmware is available for #1111011 (bwh, 20:19:32)

  7. #1112238: (n, u) linux-image-6.12.41+deb13-amd64: Second Intel P4510 NVME SSD no longer detected after Upgrade to 6.12 kernel series (Debian Trixie) (carnil, 20:19:56)
  8. #1113996: (n, uM) linux-image-amd64: self-tests for sha256 using sha256-padlock-nano failed (carnil, 20:20:40)
    1. ACTION: carnil will merge https://salsa.debian.org/kernel-team/linux/-/merge_requests/1857 (carnil, 20:23:15)

  9. #1127588: (n, ) linux-image-6.18.9+deb14-amd64: Cannot hibernate after some time of work (carnil, 20:23:33)
  10. (carnil, 20:25:27)
  11. #1128861 (waldi, 20:25:46)
  12. #1130114: (n, ) Please enable usbio module in linux kernel >= 6.18 (carnil, 20:28:39)
    1. ACTION: carnil prepares MR enabling options as mentioned in #1130114 to enable usbio module for next experimental upload (carnil, 20:31:14)

  13. #1130336: (n, u) linux-image-6.12.73+deb13-amd64: Network failure beyond first connection (carnil, 20:31:30)
  14. #1130930: (n, u) linux-image-6.12.74+deb13+1-amd64: Kernel-6.12.74+deb 13+1-amd64 fail/stuck to Unload AMD driver for single gpu passthrough (merged with #1131626) (carnil, 20:32:20)
  15. #1131025: (n, u) linux-image-6.12.73+deb13-amd64: echo vfio-pci >driver_override does not work for DVB Adapter (carnil, 20:33:23)
    1. ACTION: carnil forwards issue upstream as regression report for 6.12.y (carnil, 20:34:44)

  16. #1131431: (n, u) linux: loong64 KVM warnings (memcpy + UBSAN out-of-bounds) (carnil, 20:34:59)
    1. ACTION: bwh will look at #1131431 and forward upstream (bwh, 20:38:21)

  17. #1131546: (n, ) linux: debian/b/test-patches does not produce easy to test (unsigned) image package (carnil, 20:41:45)
  18. #1131789: (n, ) linux-image-6.19.6: GPF in ucsi_handle_connector_change on USB disconnect (carnil, 20:43:14)
    1. ACTION: bwh will forward #1131789 upstream, noting similar earlier report found by carnil (bwh, 20:51:57)

  19. #1131166: (w, +) enable uniwill platform driver (carnil, 20:53:01)
  20. #1131772: (w, ) Please enable support for Radxa Orion O6 (carnil, 20:53:42)
  21. (carnil, 20:56:29)
  22. migration excuses (carnil, 20:57:18)
  23. New upstream versions (carnil, 20:57:55)
  24. merge requests (carnil, 20:59:57)
  25. AoB (carnil, 21:01:22)


Meeting ended at 21:02:45 UTC (full logs).

Action items

  1. waldi take a look at #1126671 for further debugging and reply to reporter
  2. carnil take care of merging https://salsa.debian.org/kernel-team/linux/-/merge_requests/1854 and pick changes to other branches as labeled
  3. bwh queries upstream about #1130775 (backwards-incompatible change)
  4. bwh will check whether newer PHY firmware is available for #1111011
  5. carnil will merge https://salsa.debian.org/kernel-team/linux/-/merge_requests/1857
  6. carnil prepares MR enabling options as mentioned in #1130114 to enable usbio module for next experimental upload
  7. carnil forwards issue upstream as regression report for 6.12.y
  8. bwh will look at #1131431 and forward upstream
  9. bwh will forward #1131789 upstream, noting similar earlier report found by carnil


Action items, by person

  1. bwh
    1. bwh queries upstream about #1130775 (backwards-incompatible change)
    2. bwh will check whether newer PHY firmware is available for #1111011
    3. bwh will look at #1131431 and forward upstream
    4. bwh will forward #1131789 upstream, noting similar earlier report found by carnil
  2. carnil
    1. carnil take care of merging https://salsa.debian.org/kernel-team/linux/-/merge_requests/1854 and pick changes to other branches as labeled
    2. carnil will merge https://salsa.debian.org/kernel-team/linux/-/merge_requests/1857
    3. carnil prepares MR enabling options as mentioned in #1130114 to enable usbio module for next experimental upload
    4. carnil forwards issue upstream as regression report for 6.12.y
    5. bwh will forward #1131789 upstream, noting similar earlier report found by carnil
  3. waldi
    1. waldi take a look at #1126671 for further debugging and reply to reporter


People present (lines said)

  1. carnil (116)
  2. bwh (34)
  3. waldi (24)
  4. KGB (8)
  5. MeetBot (3)


Generated by MeetBot 0.1.4.